BGP Community Attribute实验

  Community Attribute是BGP路由里面一个可传输的,可选的属性,和MED, Weight, Local_Prf等对BGP路由选路和传播路由起到了很重要的作用。Community属性的定义可以是使用名字定义,数值定义,或者AA:NN格式定义。

  Community Attribute通过特定的community属性来对路由选路进行改变,而且这些属性可以被传播。

知名的Community属性有如下几种:

  • no-export—不通告给其他eBGP邻居,该路由尽在该AS中进行传播
  • no-advertise—不通告给其他BGP邻居,不管是eBGP还是iBGP邻居
  • internet—宣告给任何属于internet community的路由器
  • local-as—在联邦路由(Confederation)中使用,阻止数据包离开local AS

  下面是一个关于BGP Community Attribute的一个简单实验,拓扑如下:

BGP Community Attribute

R1的配置

interface loopback 0
 ip address 11.11.11.11 255.255.255.0
!
interface f0/0
 ip address 137.1.1.1 255.255.255.0
!
interface s0/0
 ip address 137.1.200.1 255.255.255.0
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay map ip 137.1.200.2 101 broadcast
!
router bgp 123
 no synchronization
 no auto-summary
 bgp log-neighbor-changes
 network 11.11.11.0 mask 255.255.255.0
 neighbor 137.1.200.2 remote-as 714
 neighbor 137.1.200.2 next-hop-self
 neighbor 137.1.1.4 remote-as 123
 neighbor 137.1.1.4 next-hop-self

R2的配置

interface loopback 0
 ip address 22.22.22.22 255.255.255.0
!
interface s0/0
 ip address 137.1.200.2 255.255.255.0
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay map ip 137.1.200.1 110 broadcast
!
router bgp 714
 bgp router-id 22.22.22.22
 no synchronization
 no auto-summary
 bgp log-neighbor-changes
 neighbor 137.1.200.1 remote-as 123

R3的配置

interface loopback 0
 ip address 44.44.44.44 255.255.255.0
!
interface f0/0
 ip address 137.1.1.4 255.255.255.0
!
router bgp 123
 no synchronization
 no auto-summary
 bgp log-neighbor-changes
 network 44.44.44.0 mask 255.255.255.0
 neighbor 137.1.1.1 remote-as 123
 neighbor 137.1.1.1 next-hop-self
 neighbor 137.1.1.1 send-community
 neighbor 137.1.1.1 route-map no_advertise out
!
access-list 1 permit 22.22.22.0 0.0.0.255
!
route-map no_advertise permit 10
  match ip address 1
  set community no-advertise

实验结果:

  R1显示关于22.22.22.0/24的路由已经打上了community属性no-advertise。

BGP Community attribute 1

  因为R1不会对这条路由宣告给其他任何BGP邻居,因此R3上不会收到这条路由了。

BGP Community attribute 2



 
 » 除非注明,本博客文章均为挨踢小茶原创,转载请以链接形式标明本文地址
该日志由 挨踢小茶 于2012年12月30日发表在 路由交换 分类下, 你可以发表评论,并在保留原文地址及作者的情况下引用到你的网站或博客。
原创文章转载请注明: BGP Community Attribute实验 | 挨踢茶馆
关键字: ,

BGP Community Attribute实验:目前有10 条留言

  1. 5楼
    Alick.Li:

    不错啊~~~~~~~~~~~~~~非常详细

    2014-11-13 下午 4:33 [回复]
  2. 4楼
    yanyp:

    兄弟你的拓扑图用的是viso么

    2013-01-09 下午 4:18 [回复]
    • 没有哦,没有用visio做过处理,是GNS3做实验直接截下来的……

      2013-01-09 下午 5:51 [回复]
      • yanyp:

        哦,gns3还可以画圈圈,线路还可写上ip,我咋就没发现呢

        2013-01-09 下午 6:15 [回复]
        • 哈哈,是有这个功能的,工具栏上就有,你看看就知道了。

          2013-01-09 下午 7:06 [回复]
          • yanyp:

            试过了,确实有,多谢小茶

            2013-01-10 上午 9:52 [回复]
  3. 地板
    016k小说网:

    不错支持了喔~!~

    2013-01-05 下午 4:22 [回复]
  4. 板凳
    网络茶馆:

    这是路由器设置的参数吗?看样是应该是公司或者企业学校用的那种大型路由器吧。我是搞PHP程序的,嘿嘿 😮

    2013-01-03 下午 8:25 [回复]
    • 是的,BGP属性一般是企业最核心的那几台路由器开启的,和Internet上所有的BGP路由器通信的。

      2013-01-04 下午 12:28 [回复]
  5. 沙发
    足球直播:

    占个沙发~支持一下 😎

    2012-12-30 下午 4:24 [回复]

发表评论



快捷键:Ctrl+Enter

无觅相关文章插件,快速提升流量